Skip to main content
Procore

Getting Started

Overview

This guide provides recommendations on best practices and tutorials for getting started.

 Note
The Procore Android app currently requires Android 7.0 (Nougat) or later. See Procore Android App: No Longer Providing Updates for Android 6.0 and Earlier.

Download for Android

Download Procore for Android

Settings