Skip to main content
Procore

Android Requirements

Software Requirements for the Procore Android App

 Important
The Procore Android app requires Android 7 or later. If your device is running Android 6 or older, you will not be able to install newer versions of the Procore app.

As we strive to provide the best experience for customers, we have ended support for Android 6.0 and earlier for the Procore Android app. This means that in order to continue receiving the latest updates for the Procore app, you must have Android 7.0 or later running on your mobile device.

Android 6.0 was released in 2015; the operating system has not been supported by Google since September 2019, and it no longer receives new security updates from Google. 

What happens if my device is still using Android 6.0 (Marshmallow) or earlier?

While you can still use an older version of the Procore app if it was already downloaded to your device, we recommend using the latest versions of Android software and the Procore app for the best stability, security, and feature compatibility. If your device remains on Android 6.0 or earlier, you will not be able to upgrade to the newer app versions of Procore.

  • At a minimum, we recommend that you update your device to at least Android 7.0 (released in 2016) so that you can continue to receive Procore app updates.
  • If possible, update your supported device to Android 11 to maintain the highest level of support by both Android and Procore.
  • If you have a device not supported by Android Nougat or later, you may consider replacing the device with one that is supported. 

How do I update my device?

For steps on how to update your device to a later version of Android, see Google's support article on checking and updating your Android version

See Also