Why did a 'transaction could not be locked' error appear when exporting a commitment change order to QuickBooks®?
Issue
When attempting to export a commitment change order from Procore to QuickBooks® with the ERP Integrations tool, an error message appeared saying the item was in use and the transaction could not be locked.
- QuickBooks® Error Message:
There was an error adding, modifying or deleting [XXXXXX-XXXXXXXXXXX] because it is already in use.
The transaction could not be locked.
Note: In the example above, [XXXXXX-XXXXXXXXXXX] denotes the unique identification number for the purchase order.
- Cause:
The export from Procore to QuickBooks® failed because the Purchase Order window was open in QuickBooks®.
Solution
To attempt to resolve this issue, close the open Purchase Order window in QuickBooks® Desktop. Then retry the export process again as follows:
- Close the open Purchase Order window in QuickBooks® Desktop.
- Navigate to the company's ERP Integrations tool.
- Click the Commitment Change Orders tab.
- Click Failed to Export.
- Follow these steps:
- Reject the commitment change order in the ERP Integrations tool. See Accept or Reject a Commitment Change Order for Export to QuickBooks® Desktop.
- Re-send the commitment change order from the Change Orders tool to the ERP Integrations tool. See Resend a Rejected Commitment Change Order to ERP Integrations for Accounting Acceptance.
- Accept the commitment change order for export to QuickBooks® Desktop. See Accept or Reject a Commitment Change Order for Export to QuickBooks® Desktop.