Why did a 'import operation took longer than set timeout' error appear when exporting a Commitment Change Order to Sage 300 CRE?
Issue
When attempting to export a Commitment Change Order (CCO) from Procore to Sage 300 CRE® with the ERP Integrations tool, an error message appeared saying the import operation took longer than the set timeout. What happened and how do I troubleshoot it?
- Error Message:
The import operation took longer than the set timeout.
- Cause:
Some possible causes for this issue include:
- A process supporting the Sage 300 CRE® server has become non-responsive.
- The hh2 synchronization client needs to be restarted.
Solution
To troubleshoot this issue, follow these steps on the Sage 300 CRE® server:
Step 1: End Task the Unresponsive Process
Follow these steps on your Sage 300 CRE® server:
- Launch Task Manager.
Tip! To learn how to launch Task Manager for your version of Microsoft Windows, visit Microsoft Support. - Click the Processes or Details tab.
- Highlight the Timberline Object Viewer (i.e., tsOject.exe).
- Click End Task.
- Repeat the steps above for every instance of the Timberline Object Viewer on the server.
Step 2: Restart the hh2 Synchronization Service
Follow these steps on your Sage 300 CRE® server:
- Start the Services MMC snap-in.
Tip! To learn how to start Services, visit Services Microsoft Management Console (MMC). - Right-click the hh2 Synchronization Service and choose Restart.
Step 3: Retry the CCO Export
After completing the steps above, retry the export process. For instructions, see Export a CCO to Sage 300 CRE®.