Skip to main content
Procore

Why is my form template not loading?

If your form template is not loading and you receive an error message indicating that "your PDF viewer may not be able to display this type of document," or that "You need the latest version of the PDF viewer," then the uploaded PDF may only be compatible with Adobe Reader or Adobe Acrobat. You can resolve this issue by recreating the fillable PDF in an unrestricted file format before uploading the new form template to Procore.

See Also