Skip to main content
Procore

Procore Sync: Release Notes

Below are notable changes for Procore Sync. Note: Procore Sync must be installed on a system running Microsoft Windows 7 or newer. 

Recent Changes

No notable changes at this time.

All Changes

  • Was this article helpful?