Skip to main content
Procore

Quel est l'impact de la mise à niveau du Protocole de sécurité de la couche transport v1.2 sur les utilisateurs?

Réponse

Pour la majorité des utilisateurs de Procore, la mise à niveau vers le protocole de sécurité de la couche transport (TLS) v1.2 n'aura aucun impact négatif sur les performances, la stabilité ou la sécurité. Il peut toutefois y avoir certains aspects de la mise à niveau dont certains utilisateurs doivent être conscients. Ces considérations sont traitées dans les sections suivantes.

Contexte

L'architecture de sécurité réseau de Procore repose sur le protocole TLS (protocole de sécurité de la couche transport) pour garantir une interaction sécurisée entre l'utilisateur et Procore sur Internet sans que les transmissions ne soient vulnérables aux entités externes. Le protocole TLS crypte un canal entre deux points finaux (par exemple, entre un navigateur Web et un serveur Web) pour assurer la confidentialité et la fiabilité des données transmises sur le canal de communication. Le principal avantage de TLS est la protection des données d'applications Web contre la divulgation et la modification non autorisées lorsqu'elles sont transmises entre les clients (navigateurs Web) et le serveur d'applications Web, et entre le serveur d'applications Web et le programme secondaire ou d'autres composants non basés sur un navigateur.
 

Soucieux de protéger vos données et de se conformer aux normes de l'industrie, Procore ne prendra en charge que les connexions réseau TLS 1.2 à partir du début du deuxième trimestre 2019. Les utilisateurs devront se connecter à Procore en utilisant le protocole TLS 1.2 pour éviter toute interruption de service.

Dates et étapes importantes

Voici quelques dates et étapes importantes liées à la mise à niveau de TLS v1.2 :

  • Février 2019 - Annonce initiale de la mise à niveau de TLS v1.2, le support de TLS v1.0/1.1 est obsolète.
  • 1 mai 2019 - Fin du support pour TLS v1.0/1.1. Seules les connexions TLS v1.2  seront prises en charge après cette date.
Versions de navigateurs qui prennent en charge le protocole TLS v1.2

Afin d'assurer un service ininterrompu, les utilisateurs de Procore doivent adopter l'une des versions de navigateur suivantes qui prennent en charge TLS v1.2.

  • Google Chrome - v30 ou version ultérieure
  • Mozilla Firefox - v27 ou ultérieur
  • Microsoft Internet Explorer - v11 ou version ultérieure
  • Safari pour Mac OS X - v7 ou ultérieur
  • Edge pour Windows 10

Vous pouvez utiliser cet outil pratique fourni par SSL Labs pour déterminer si la version actuelle de votre navigateur prend en charge TLS v1.2. (Remarque : Si vous n'arrivez pas à accéder aux sites SSL Labs énumérés ci-dessus, vérifiez auprès de votre équipe informatique que le domaine www.ssllabs.com est bien sur liste blanche dans votre environnement.)

Prise en charge des appareils mobiles

Appareils Apple iOS
  • Tous les appareils Apple fonctionnant sous iOS v9.0.0.0 et versions ultérieures sont compatibles avec TLS 1.2.
  • Tous les appareils iOS autres que l'iPhone original (2007), l'iPhone 3G, l'iPhone 3GS, l'iPhone 3GS, l'iPhone 4 et l'iPad original (2010) peuvent être mis à niveau vers au moins iOS 9.
  • Les versions actuelles de Procore pour iOS nécessitent iOS 11 ou une version ultérieure.
Appareils Android
  • Les appareils Android fonctionnant à partir de la version 4.4 du système d'exploitation Android sont compatibles avec TLS 1.2.
  • Les appareils Android fonctionnant sous v4.1 à v4.3 du système d'exploitation Android peuvent prendre en charge TLS 1.2 selon la configuration du système, mais sont désactivés par défaut pour le support de TLS 1.2.
  • Les appareils Android fonctionnant sous la version 4.0 ou antérieure du système d'exploitation Android ne sont pas compatibles avec TLS 1.2.
  • Was this article helpful?