Why did a 'transaction could not be locked' error appear when exporting a commitment change order to QuickBooks®?
Issue
When attempting to export a commitment change order from Procore to QuickBooks® with the ERP Integrations tool, an error message appeared saying the item was in use and the transaction could not be locked.
- QuickBooks® Error Message:
There was an error adding, modifying or deleting [XXXXXX-XXXXXXXXXXX] because it is already in use.
The transaction could not be locked.
Note: In the example above, [XXXXXX-XXXXXXXXXXX] denotes the unique identification number for the purchase order.
- Cause:
The export from Procore to QuickBooks® failed because the Purchase Order window was open in QuickBooks®.