Skip to main content
Procore

¿Cómo la actualización de la seguridad de la capa del transporte v1.2 afecta a los usuarios?

Respuesta

Para la mayoría de los usuarios de Procore, la actualización de la seguridad de la capa del transporte (TLS) v1.2 no tendrá ningún impacto negativo en el rendimiento, la estabilidad o la seguridad. Sin embargo, puede haber algunos aspectos de la actualización que algunos usuarios deben tener en cuenta. Estas consideraciones se tratan en las siguientes secciones.

Contexto

La arquitectura de seguridad de red de Procore se basa en el protocolo de la seguridad de la capa del transporte (TLS) para garantizar que la interacción del usuario con Procore a través de Internet se produzca de forma segura sin que las transmisiones sean vulnerables a entidades externas. TLS cifra un canal entre dos puntos finales (por ejemplo, entre un navegador web y un servidor web) para proporcionar privacidad y fiabilidad de los datos transmitidos a través del canal de comunicaciones. La principal ventaja de TLS es la protección de los datos de las aplicaciones web frente a la divulgación y modificación no autorizadas cuando se transmiten entre clientes (navegadores web) y el servidor de aplicaciones web, y entre el servidor de aplicaciones web y el back-end (aplicación que se conecta a uno de los puntos finales orientados al servicio), u otros componentes empresariales no basados en navegadores.

Debido a la preocupación por proteger sus datos y cumplir con los estándares de la industria, a partir de principios del segundo trimestre de 2019, Procore sólo será compatible con las conexiones de red TLS 1.2. Los usuarios deberán conectarse a Procore utilizando el protocolo TLS 1.2 para evitar cualquier interrupción en el servicio.

Importantes fechas y logros alcanzados 

He aquí algunas fechas y logros importantes relacionados con la actualización a TLS v1.2:

  • Febrero de 2019 - Anuncio inicial de la actualización a TLS v1.2, soporte para TLS v1.0/1.1 obsoleto.
  • 1 de mayo de 2019 - Fin del soporte para TLS v1.0/1.1. Sólo las conexiones de TLS v1.2  serán compatibles después de esta fecha.
Versiones del navegador compatibles con la seguridad de la capa del transporte (TLS) v1.2

Para garantizar un servicio ininterrumpido, los usuarios de Procore deben adoptar una de las siguientes versiones de navegador compatibles con TLS v1.2

  • Google Chrome - v30 o posterior
  • Mozilla Firefox - v27 o posterior
  • Microsoft Internet Explorer - v11 o posterior
  • Safari para Mac OS X - v7 o posterior
  • Edge para Windows 10

Puede utilizar esta práctica herramienta proporcionada por los laboratorios SSL para determinar si la versión actual de su navegador es compatible con TLS v1.2. (Nota: Si no puede acceder a los sitios de los laboratorios SSL mencionados anteriormente, compruebe con su equipo de tecnología para verificar que el dominio www.ssllabs.com aparezca en la lista blanca adecuada en su entorno.)

Soporte para dispositivos móviles

Dispositivos iOS de Apple
  • Todos los dispositivos Apple que ejecutan iOS v9.0.0 y posteriores son compatibles con TLS 1.2.
  • Todos los dispositivos iOS que no sean el iPhone original (2007), iPhone 3G, iPhone 3GS, iPhone 4 y iPad original (2010) pueden actualizarse como mínimo a iOS 9.
  • Las versiones actuales de Procore para iOS requieren iOS 11 o posterior.
Dispositivos Android
  • Los dispositivos Android que ejecutan v4.4 y posteriores del sistema operativo Android son compatibles con TLS 1.2.
  • Los dispositivos Android que ejecutan las versiones 4.1 a 4.3 del sistema operativo Android pueden admitir TLS 1.2 dependiendo de la configuración del sistema, pero están deshabilitados para la compatibilidad con TLS 1.2 de forma predeterminada.
  • Los dispositivos Android que ejecutan v4.0 y versiones anteriores del sistema operativo Android no son compatibles con TLS 1.2.